FeaturedFrequently Asked Questions

PHP 5.6 and 7.0 End of Life

What is happening?

Popular PHP versions 5.6 and 7.0 are going End Of Life in December, 2018. After this happens, these versions will no longer receive updates or patches. Versions 7.1 and 7.2 will be supported going forward, but this is the end of the line for PHP 5.

Sites hosted by JerseyConnect that run PHP 7.0, 5.6, or older versions will continue to receive backported security fixes. However, sites hosted on other servers may not, so check with your host.

CMS programs will begin to require newer PHP versions for updates, and add-ons or plugins may not work on these older PHP versions. PHP versions 7 and later make your site load up to 50% faster than version 5, and introduce a number of new features and libraries.

Is my site affected?

If your site is hosted by JerseyConnect and you have not changed your PHP version, you are probably running PHP 5.6 and should upgrade.

How can I tell if my site is compatible with new versions of PHP?

If your site is being maintained with patches and updates, it will be compatible with the new versions of PHP. If your site is older, or if it runs custom code, it may not be compatible.

CMS What to check
WordPress For WordPress sites, you can use the PHP Compatibility Checker plugin to check for issues with PHP 7.1 or 7.2.
Drupal For Drupal sites, a minimum Drupal version of 7.55 or 8.5.0 is recommended. Drupal 7 will not support PHP 7.2 until the forthcoming Drupal 7.61 release.
Joomla For Joomla sites, a minimum version of 3.5 is recommended for PHP 7.1, and version 3.8 is recommended for PHP 7.2. Make sure to check your extensions for updates.

For other CMS programs, check your vendor’s documentation for compatibility info.

How can I see my PHP version and upgrade?

Use the Select PHP Version icon in the web hosting control panel to view your PHP version and select a new one.

This page also lets you set PHP options and add or remove any PHP modules you might need.

 

Use this icon to view your site’s PHP version or select a new one